JUNCHAO

gripper can't be initialized; example code error reported

Recommended Posts

Hello,

I tried to run the gripper example with command "$ rosrun intera_examples gripper_keyboard.py", but it turned out with few errors. Few functions like "map_keyboard(args,limb)", "gripper=intera_interface.Gripper(limb)" have errors and the last two showed that the gripper is not attached. See screen shot attached. We bought Pneumatic Large Gripper Kit and assembled by exactly following the instruction and I am sure it was attached properly, but I don't know why it shows the gripper is not attached.

Similarly, when I tried to run the second example with command "$ rosrun intera_examples joint_position_keyboard.py", it shows "Could not initialize the gripper". I wonder do I need to type any command to let the robot know the gripper is attached? 

Junchao Li

Screenshot from 2018-04-06 13_57_02.png

Screenshot from 2018-04-06 14_10_11.png

Share this post


Link to post
Share on other sites

Hi Junchao,

The Pneumatic Large Gripper Kit is actually a "ClickSmart Gripper" which is a bit different than the electric parallel gripper that these examples were written for. The ClickSmart grippers need to be configured once in Intera MFG mode, then you can use them with the SDK.   Essentially, to use the ClickSmart series with Sawyer SDK, it requires booting Sawyer into the Manufacturing mode to complete the gripper configuration. The general flow is booting into the Intera Manufacturing software, configure the ClickSmart end effector, save that configuration to the ClickSmart, boot into the SDK mode, use the SDK to read and command the ClickSmart signals. There is a more comprehensive example forthcoming, but in the meantime follow these steps (and linked tutorials) to configure and then use your ClickSmart gripper:

1) Boot into Intera by booting into FSM, and selecting the next boot mode to be Intera:
Field Service Menu: http://sdk.rethinkrobotics.com/intera/Field_Service_Menu_(FSM)

2) connect to the robot via ethernet, open up Intera Studio from your Chrome web browser, request access from the robot:
Intera Studio Connection: http://mfg.rethinkrobotics.com/intera/Robot_Screen#Connecting_To_Intera_Studio

3) Configure the Clicksmart (end effector pose, mass, center of mass) using the End Effector Panel. This tutorial explains in detail:
Configure tooling: http://mfg.rethinkrobotics.com/intera/End_Effectors_Panel

4) Reboot into the SDK by booting into the FSM and selecting (SDK) as the next boot mode

5) Follow the gripper_cuff_control example as to how programmatically to retrieve the signals from the clicksmart and actuate the gripper:
https://github.com/RethinkRobotics/intera_sdk/blob/master/intera_examples/scripts/gripper_cuff_control.py

Please feel free to ask any question you encounter during this process. They will help me inform the wiki tutorial.

Hope this helps!

~ Ian

Share this post


Link to post
Share on other sites

Hello Ian,

 

I'm meeting same issue.

I set up gripper configuration from Intera Stadio.

I checked cuff button is available in Intera.

After reboot, I also tried SDK mode.

I run "gripper_cuff_control.py" and push circle or dash button on cuff.

But, cuff button was not available in SDK. I checked signal High/Low by osciloscope.

How can I do?

 

Best regards.

Share this post


Link to post
Share on other sites

Hi Ian McMahon

This work for me, thank you.

But I have doubts about how to use the second subtool in a PSG Gripper, I searched in the code, but I did not find how change between Subtool 1 to Subtool2

How can I do test?

 

Best regards.

 

Share this post


Link to post
Share on other sites

Hi Heriberto,

 

I can change between Subtool 1 to Subtool2.

Please check "clicksmart_plate.py" in intera_interface folder.

I think "self.endpoint_map.keys()" change tools.

For example, change [0] to [1].

Or check json information, so you can confirm which tool is active.

 

Best regards.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now