Unable to ping Sawyer


Recommended Posts


I've never worked with Ubuntu and now I am kinda lost what to do. Before describing the problem I'll tell you what I already did:

1) installing Ubuntu 14.04.05 as VM

2) Setting up ROS, the tutorials work

3) I used http://sdk.rethinkrobotics.com/intera/Workstation_Setup and http://sdk.rethinkrobotics.com/intera/Networking to connect directly to Sawyer. In the first tutorial it fails at the commando "rostopic list" (ERROR: Unable to communicate with master!) and in the second tutorial I can't ping the robot. 

env | grep ROS

returns i.a. ROS_MASTER_URI=http://<serial number>.local:11311 and ROS_HOSTNAME my computer. I can also ping my computer, but when I try to ping Sawyer with 

ping <Serial number>.local

it returns "unknown host". A colleague has Sawyer connected via a router and it works fine. So where is the problem with direct connection?

Link to comment
Share on other sites

Hi Ian,

I want to use Direct Connect. When I follow the tutorial the terminal only shows my workstation (multiple times) after entering 

$ avahi-browse -a -r

 but I don't see the local hostname of the robot.

Link to comment
Share on other sites

Hi Don,

yes, I use the port on the outside. 

Meanwhile I tried to connect via Router and this also doesn't work. I now think it has probably something to do with my Virtual Machine, because I am able to connect to the robot using Intera and Chrome in MS Windows (which means the cable should be fine).

Link to comment
Share on other sites

Hi Stuwe,

I sent you this information in our email exchange but I wanted to post it to this topic as well in case other users have the same issue.  We have seen networking issues with VMs in the past.  The issues are typically related to opening the proper ports on the on the VM but we strongly recommend using a direct installation of Ubuntu as these issues can be difficult to resolve.

In some cases, users have created a dual boot on their system so the can continue to run Windows as well.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.