Sawyer not connecting to ROS


jorgegalds_DON
 Share

Recommended Posts

I followed the steps on networking from the intera website and tried to run the examples. But when I tried to, the message of "unable to communicate with master" always appeared. The intera.sh file has been correctly updated and don't know what other approach to take. Any extra packages that need to be downloaded / steps to take other than the ones described in the website?

  • Like 3
Link to comment
Share on other sites

  • 4 weeks later...

I ran the ifconfig command to check what was the actual name of the ethernet connection (as it was different from eth0). With the correct name, I ran the sudo avahi-autoipd [eth name] on a separate terminal window and left it running on the background. After this, I completed the "Hello Robot" tutorial without a problem. 

Link to comment
Share on other sites

  • 1 month later...
  • 4 weeks later...

Hello, jorgegalds_DON, Conti Michele,  Enrico Mattei,

Sorry for late reply in here,

If you are running Intera software, please check out https://rethinkrobotics.interaforum.com/forum/3-using-intera/ for more information. 

For SDK, please try to ping your robot from your workstation, make sure ping is working. Also, you can try to set up a static IP on the robot in robot FSM when you use robot hostname in intera.sh.

Hope this helps.

-Shiwei

 

 

Link to comment
Share on other sites

@Conti Michele:  Your screen shows that your are running Intera Studio, which indicates that the robot is booted up into the manufacturing mode, not the SDK mode.  You need to power down the robot, then boot into the field service Menu (FSM) http://sdk.rethinkrobotics.com/intera/Field_Service_Menu_(FSM)

From the FSM, you need to select SDK, then reboot again.  When the robot boots up, you will just see the Rethink logo on the head screen.  This is how you know you are in the SDK.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share