Gripper does not connect to Sawyer


gabrigoo
 Share

Recommended Posts

Hello,

I have been trying to connect this gripper to the Sawyer however it doesn't seem to properly work.

 

Basically, if I run the example code 

$ rosrun intera_examples gripper_cuff_control.py

everything works perfectly.

 

However, if I run this simple code:

# Sawyer Packages
import os
import rospy
import intera_interface
from intera_interface import Gripper

# Initialize ROS node, registering it with the Master
rospy.init_node('Sawyer_AssistiveGym')
# Create an instance of intera_interface's Limb class
limb = intera_interface.Limb('right')
# Enable the robot in case the emergency button was pressed
os.system('rosrun intera_interface enable_robot.py -e')
limb.move_to_neutral(timeout=15.0, speed=0.6)

# Use Gripper
arm = 'right_gripper'
_gripper = Gripper('right')

then I get the following error:

[INFO] [1635963926.594737]: Robot Enabled
[WARN] [1635963927.249393]: Specifying gripper by 'side' is deprecated, please use full name (ex: 'right_gripper').
Traceback (most recent call last):
  File "/home/gabrigoo/assistive-gym/SawyrExp.py", line 17, in <module>
    _gripper = Gripper('right')
  File "/home/gabrigoo/ros_ws/src/intera_sdk/intera_interface/src/intera_interface/gripper.py", line 47, in __init__
    intera_dataflow.wait_for(
  File "/home/gabrigoo/ros_ws/src/intera_sdk/intera_interface/src/intera_dataflow/wait_for.py", line 42, in wait_for
    raise OSError(errno.ETIMEDOUT, timeout_msg)
TimeoutError: [Errno 110] Failed to get gripper. No gripper attached on the robot.

Why is this happening?

 

Thanks in advance!

Link to comment
Share on other sites

  • 8 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share