Sawyer robot enable failed


JUNCHAO
 Share

Recommended Posts

I have been using Sawyer in SDK mode for a while, but today when I was trying to enable the robot again, it failed. I did all the process as usual. I use Ethernet cable with switch for connection, "autoipd" to generate the IP address and I double checked the IP in "intera.sh", then run the "intera.sh" shell and run the "rosrun intera interface enable robot.py -e". There is one error displayed when I ran it. I can't find some good resources online for that, so I have to ask to Sawyer team to see if you guys can help me out. I used another laptop with same sawyer and ROS package installed, but still has the same error. I ran all the enable files, they all appears that have one same error. I guess would it be the issue from robot? I haven't changed anything after it was successfully enabled last time. I have been doing these steps for months, but don't know what happened today.

Below is the error when I run all the "enable" files with " -e, -d, -h, -s":

robotics@robotics-Latitude-E5470:~/ros_ws$ gedit intera.sh
^C
robotics@robotics-Latitude-E5470:~/ros_ws$ ./intera.sh
[intera - http://021705CP00093.local:11311] robotics@robotics-Latitude-E5470:~/ros_ws$ rosrun intera_interface enable_robot.py -e
  File "/home/robotics/ros_ws/src/intera_sdk/intera_interface/scripts/enable_robot.py", line 54
    print rs.state()
           ^
SyntaxError: invalid syntax
[intera - http://021705CP00093.local:11311] robotics@robotics-Latitude-E5470:~/ros_ws$ 
 

 

Thanks a lot,

Junchao Li

 

Link to comment
Share on other sites

Yes, I have the same issue with Intera too. I can't access Intera through Google Chrome Browser with the Ethernet cable connected.

In the Sawyer SDK mode, I tried to skip "print rs.state()" in the file and run "rs.enable()" and "rs.disable()" etc. They all have the same syntax error. It looks like the library is missing. However, I have two laptops with the same package installed and environment set up and I haven't change anything since the first time I used them, but they all have the same error when I ran this file.

Both robot and laptops were offline when I ran them. The software and packages are still the last version. I guess would it be the issue with the robot. Really need Sawyer Team Support!

Link to comment
Share on other sites

  • 2 weeks later...

I just fixed the issue about the failure of the enabling, so this can be a reference for anyone has the same issue. First of all, I googled and found out that Anaconda's libraries might have conflict with few ROS libraries. If you have Anaconda installed as the programming IDE, please check the python's and its libraries' version. It caused some errors. I removed Anaconda and reinstalled ROS then the problem fixed. Please post comments if you have better solution.

Another issue is when I connected to the Sawyer robot, I just turned off the WIFI but not the network connection. I remember I used to be able to connect robot in this mode, but this time I can't ping the robot's host name and IP,  and it showed up " unable to communicate with master!" when I called it. Later on I figured out that I have to disable both the WIFI connection and the network connection in Ubuntu Settings, in order to ping the robot and build up the connection. If you have same problem then don't forget to check the connection.

Junchao Li

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share