Commands Not Recognized


Recommended Posts

Whenever I run any python scripts I get an attribute error. The example below is trying to get the position of the arm. I am able to ping sawyer just fine and my system did work a week ago. I tried re-installing the sdk once this problem occurred. Is there any way to fix this issue?

Traceback (most recent call last):
	File "", line 6, in <module>
   		limb = intera_interface.limb('right')
AttributeError: 'module' object has no attribute 'Limb'


Link to comment
Share on other sites

I'm not 100% sure, as I do not know the contents of, but your issue might be that 'Limb' needs to be capitalized when instantiating the class. Does something like this work in your environment?


import rospy

import intera_interface


r = intera_interface.Limb('right')

Link to comment
Share on other sites

That is essentially what is doing. I inserted the code below that gives me the error. It does what you asked then prints the output into the terminal. The error happens when it gets to limb = intera_interface.Limb('right') 

import rospy
import intera_interface


limb = intera_interface.Limb('right')

robotPose = limb.endpoint_pose()
print robotPose


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.