Sign in to follow this  

Gripper does not connect to Sawyer

Recommended Posts


I have been trying to connect this gripper to the Sawyer however it doesn't seem to properly work.


Basically, if I run the example code 

$ rosrun intera_examples

everything works perfectly.


However, if I run this simple code:

# Sawyer Packages
import os
import rospy
import intera_interface
from intera_interface import Gripper

# Initialize ROS node, registering it with the Master
# Create an instance of intera_interface's Limb class
limb = intera_interface.Limb('right')
# Enable the robot in case the emergency button was pressed
os.system('rosrun intera_interface -e')
limb.move_to_neutral(timeout=15.0, speed=0.6)

# Use Gripper
arm = 'right_gripper'
_gripper = Gripper('right')

then I get the following error:

[INFO] [1635963926.594737]: Robot Enabled
[WARN] [1635963927.249393]: Specifying gripper by 'side' is deprecated, please use full name (ex: 'right_gripper').
Traceback (most recent call last):
  File "/home/gabrigoo/assistive-gym/", line 17, in <module>
    _gripper = Gripper('right')
  File "/home/gabrigoo/ros_ws/src/intera_sdk/intera_interface/src/intera_interface/", line 47, in __init__
  File "/home/gabrigoo/ros_ws/src/intera_sdk/intera_interface/src/intera_dataflow/", line 42, in wait_for
    raise OSError(errno.ETIMEDOUT, timeout_msg)
TimeoutError: [Errno 110] Failed to get gripper. No gripper attached on the robot.

Why is this happening?


Thanks in advance!

Share this post

Link to post
Share on other sites


Did you ever solve this problem? I'm encountering the same issue


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this