Sign in to follow this  
FontanaSimon

Cannot Control Sawyer using SDK

Recommended Posts

Hi,

I am currently trying to control the Sawyer using the Intera SDK(v.5.3). I am able to ping the Robots IP and its *.local hostname. I am also able to communicate with the ROS Master. This means i can read pretty much all the data(angles, force, effort etc.).

My Problem is, that i cant send action commands to the robot. For example: I can read the state of the robot using "rosrun intera_interface enable_robot.py -s" and I get the following response:
homed: True
ready: True
enabled: True
stopped: False
error: False
lowVoltage: False
estop_button: 0
estop_source: 0

If I now try to disable the robot using "rosrun intera_interface enable_robot.py -d" I get an error and nothing happens. The same occurs when I try to start intera_examples like head_wobbler.py, lights_blink.py etc.. When trying to move the robot using the python shell the robot doesn't move, but there is no error message. (I can confirm, that the the functions are writing data in their respective topic, for example: "limb.move_to_joint_positions()" function is writing data to the </robot/limb/right/joint_command>-topic.)

I looked intro the source code and all of those errors come from timeouts. (In the "limb.move_to_joint_positions()" function a timeout happens, but it is not raised)

Does anybody have an idea what could cause this? 

Cheers and many thanks

Share this post


Link to post
Share on other sites

I  think you have a problem of communicate between Robot and your computer.

the first time i try it like you, after that i can get the date like angles, force etc, but when i try to move my robot, it not work.

So, i had to correct my communicate and after that it work. (if you can do ping  <hostname.local> and your computer, it will have to work)

Share this post


Link to post
Share on other sites

For all future visitors, I have found the problem:

It seems our company workstation have some kind of firewall or other networking settings that block the avahi mDNS service. To confirm my finding I installed vanilla ubuntu on an old workstation we had lying around. With that workstation it worked like a charm.

Cheers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this