lr101095

vibrating model

Recommended Posts

While running the sawyer simulation in intera 5.2, i can see that the model is vibrating.

Calling  rostopic echo robot/limb/right/gravity_compensation_torques, you can see that there are changes being constantly made in actual_position, actual_velocity, actual_effort  and gravity_only.

I compared the same topic to the real robot, and i saw no changes in the output.

Does anyone know why this happens in the simulation or how to resolve it?

Share this post


Link to post
Share on other sites

Hi LR,

The caveat when working with the simulator is that it will never perform exactly the same as the real robot. That said, you have indeed encountered a bug with how gravity_compensation_torques are being calculated: one of the KDL::JntArray vectors being used to calculate the gravity torques is being used uninitialized. The uninitialized values cause the calculated simulated gravity torque to vary a fair amount, which causes jitter. I have a fix for this that has not been yet merged into master, but I will hotfix the simulator shortly:

https://github.com/RethinkRobotics/sawyer_simulator/compare/master...kinematics_gravity_torques#diff-3d709d3c805e7153135d0d32960a5b21L449

I will update this topic with details once merged into `master`. In the mean time, if you like living life on the bleeding edge, free to checkout the kinematics_gravity_torques branch on github:
 

$ roscd sawyer_gazebo && git fetch origin && git checkout kinematics_gravity_torques
$ roscd sawyer_robot && git fetch origin && git checkout gravity_inertia
$ catkin build

Best,

~ Ian

Share this post


Link to post
Share on other sites

Hi Ian,

I was trying to checkout the kinematics_gravity_torques branch as you suggested, but that branch doesn't seem to exist anymore.
The link you provided also doesn't make comparisons between branches anymore.

I was able to checkout gravity inertia, but there is still a little bit of vibration from one of the joints.

Is there any update regarding the master on git?

Cheers,
Luke

Share this post


Link to post
Share on other sites

Hi Ian,

I tried to implement what you suggested, but the joints are still vibrating. In addition to that, I am unable to manipulate any of the joints after joint 3 when trying to run my program. Even when i exit the program, i am still unable to move the robot.

Before running the program, i am able to use joint_position_keyboard to move the robot.

Can you suggest any reason as to why this happens?

Regards,
Luke

Share this post


Link to post
Share on other sites

This has been fixed and released. Assuming you already have your workspace configured for sawyer_simulator, simply run:

$ cd ~/ros_ws/src
$ wstool update
$ catkin build

to pull in the latest changes for Sawyer Simulator.

Share this post


Link to post
Share on other sites

Hi Ian,

I've updated as you suggested. However, i'm still seeing unnecessary vibrations in right_j4 when looking at the robot/joint_states/effort through rviz.

The vibrations in right_j4 are also affecting the joint torque efforts in right_j3 and right_j6. The consequential vibrations in right_j6 has a negative effect on the application i'm working on, causing inaccurate readings from a force/torque sensor attached to the end-effector of the robot.

Is there anything you can suggest that may fix this?

Share this post


Link to post
Share on other sites

In addition to this, while trying to update, i got the following:
image.png.ec3e2b4e441605ca06ef085fe2f0c323.png

Any suggestions?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now