Arunava Nag

Cannot communicate to Sawyer ROS Interface

Recommended Posts

Hello,
 
I am having a Sawyer. My system is running ROS Kinetic in Ubuntu 16.04. 
I tried using the sh script, it ssh s myself inside how ever I cannot communicate with the ROS master. 
I tried using a virtual machine running ROS Indigo and Ubuntu 14.04. I still couldn't communicate to the ROS master. 
 
In all the cases i could ping the system from my workstation. Also in my SDK mode, it throws camera calibration error. I have attached a screenshot of that. 
 
Kindly help.

WhatsApp Image 2017-09-14 at 4.23.22 PM (1).jpeg

Share this post


Link to post
Share on other sites

Hi Arunava,

Can you please confirm the software version installed on your robot?  If you are not running 5.1.2.4, I recommended downloading the updated files from the downloads section of the forum and updating your robot to the latest version.

Best,

Don

Share this post


Link to post
Share on other sites

Hi Arunava,

In addition, we will be contacting you off line in order to follow up on your issue as this is a potential hardware issue.

If any other users see this message, please email support@rethinkrobotics.com with details including the serial number of your robot.

Best,

Don

Share this post


Link to post
Share on other sites

Hi Don,

Thanks for your response.

First of all, I have been using the google group for Baxter since 2015 and this forum is quite new to me. I have clicked on the notify me, however, it did not send me any notification of your responses. Sorry for the delay. 

Please find attached the version I am running.

image.png.7230c206bd7c86e194cc5e82d67a94f4.png

 

The camera calibration issue is only visible in SDK mode and it's occasional, that is, I don't see it after every bootup. My distributor advised me to run the camera tests from FSM which I did and I got OK for both the results FYI.

Share this post


Link to post
Share on other sites

Hi Arunava,

I will continue to follow up with you off line regarding the camera issue, this may be a hardware error.

Regarding following the forum, unfortunately, you need to follow each individual topic if you want to see replies.  When you are following the forum, you will be notified of new posts but in order to see replies, you need to follow the specific topic.

Regarding the C++ question, I recommend creating a separate post.

Best,

Don

Share this post


Link to post
Share on other sites

Sorry Arunava Nag, I have the same problem of connection with my Sawyer. In my Konsole appear the follow error message, after rostopic list command:

ERROR: Unable to communicate with master!

How did you solve the connecting problem?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now