Eash

Unable to ping to ROS Master

Recommended Posts

We are following the installation tutorial and are currently on the "Hello Robot."

The problem we are facing is verifying our connection to the ROS Master. 

In the tutorial, it states that the ROS Master is the serial number on the baxter arm.

When we attempt to ping to the ROS Master URI (serial number), we get unknown host. 

________________________________________________________________________________________________

I.e.

[intera - http://021xxxRPxxxxx.local:11311] user@ubuntu:~/ros_ws$ ping 021xxxRPxxxxx.local

ping: unknown host 021xxxRPxxxxx.local

_______________________________________________________________________________________________

Also we have successfully pinged to the controller with its serial number/IP address. 

Are we suppose to ping to the controller with its serial number or the arm itself?

Edited by Eash
formatting

Share this post


Link to post
Share on other sites

Hi Eash,

It seems you are pinging your Robot's serial number, rather than your Controller Box's serial number. Sawyer is a bit different than Baxter in that the Controller Box is separate, and your robot's hostname is defaulted as the Controller's serial number. The serial number can be located on the back of the robot's Controller Box. So instead it will look something like:

[intera - http://021xxxCPxxxxx.local:11311] user@ubuntu:~/ros_ws$ ping 021xxxCPxxxxx.local

ping: unknown host 021xxxCPxxxxx.local

Let us know if this solves your issue.

Best regards,

~ Ian

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi Ian,

Thank you for the reply. That is what we thought yesterday too, however, as it can be seen on the tutorial/ walkthrough, they specify to use the S/N on the robot (which is a mistake, as you have pointed out)

http://sdk.rethinkrobotics.com/intera/Serial_Number

We will use the controller's S/N today and update on any news.

Share this post


Link to post
Share on other sites

Hi Ian,

A workaround has been found, which is partly the solutiuon you said and opting to use a direct connection to the controller via ethernet cable. 

However, a new issue has risen. The issue is running the example programs, as none of the example programs work. For example the " rosrun intera_examples joint_torque_springs.py " example does not move the robot to a "neutral pose" or even the " rosrun intera_examples camera_display.py " the terminal returns with

splay.py
Initializing node... 
[WARN] [WallTime: 1484625635.265185] Timed out waiting for command acknowlegment...
[WARN] [WallTime: 1484625640.309822] Timed out waiting for node interface valid...
[ERROR] [WallTime: 1484625640.310784] Failed to stop right_hand_camera from streaming on this robot. Unable to start streaming from head_camera
[INFO] [WallTime: 1484625640.319965] Camera_display node running. Ctrl-c to quit

Overall, none of the examples work. Do you know why this happening?

Edited by Eash
Added information

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now