Leaderboard


Popular Content

Showing content with the highest reputation since 12/08/2016 in all areas

  1. 3 points
    Hi Live, You will need an external air supply. The vacuum grippers sold by Rethink Robotics include vacuum generators so standard out blowing air will work but you will need to supply the air as the robot does not have an internal compressor. In addition, the robot components use 6mm air hoses and connections. If you have a 12mm hose, you may need an adapter to connect to the 6mm components. Finally, we recommend using 60-90psi. Best Regards, Don
  2. 3 points
    Hello all, I recently completed the process of getting a Kinectv2 working with Sawyer and I'd like to record the steps I took for anyone who might also want to do this. As a quick primer, Kinectv1 is better on edges, but Kinectv2 is much better outdoors, and has higher depth resolution To start I installed libfreenect2 on my workstation. https://github.com/OpenKinect/libfreenect2 I had some trouble when I was using ROS Indigo and Ubuntu 14.04 (as recommended in the Rethink workstation setup) However I updated my machine to ROS Kinetic and Ubuntu 16.04 and as far as I am aware Sawyer works fine. Having done that I followed the libfreenect2 instructions for Ubuntu 16.04 and verified that my install was working by running Protonect from the build folder. After that I installed python bindings for libfreenect2, pylibfreenect2. https://github.com/r9y9/pylibfreenect2 (NOTE: Do not bother with pyfreenect2, it is not maintained and I don't think it ever actually worked) If you want skeleton tracking you should look into OpenNI. I dont have any experience with this though I am working on kinectv2+sawyer robot api, still a wip though. Anyways after the above steps all of the software is taken care of. Then comes the issue of actually mounting the Kinectv2 to the robot. The kinectv2 naturally angles upward by about 15 degrees or so, and I wanted a cheap and easy way to affix it to Sawyer, so I 3-d printed the below mounting block. It has a (6mm) hole in it for screwing the kinectv2 to it, and the bottom is a circular recess that measures ~82.3mm so that it fits very snugly onto Sawer's head (with a bit of filing down). The head will pan to the side long before the mounting block slips. It takes a great deal of force to remove it, which is good as there isnt anything to lock on to without an elaborate setup or drilling a hole into Sawyer. If anyone wants the .stl of the block it is here https://github.com/jshube2/sawyer_mods I can try to answer questions about getting the kinectv2 setup. I likely experienced every possible error message. -Josh
  3. 2 points
    Hi Luke, I just posted that the new Sawyer SDk is now available! Good luck with your project! Best, Mike
  4. 2 points
    Hi Luke, We have announced the Sawyer SDK update, with Gazebo integration, for mid-March Release. Its coming soon, so please stay tuned, thank you! Best, Mike
  5. 2 points
    Hi senaa. We don’t comment on timelines for upcoming features, but I can confirm that Gazebo integration for Sawyer is under development. Best, ~ Ian
  6. 1 point
    Is there a timeline on support for Sawyer simulation through Gazebo? I noticed there was a Rethink internship advertised earlier in the year with this listed as one of the tasks, hoping there has been some progress..
  7. 1 point
    Hi, My colleagues and I have been trying for quite some time to get IK Fast to build for the Sawyer Arms, with no success. We've installed OpenRave successfully and verified the installation, but we've been having trouble getting the ik_fast module to generate the solver cpp file for us. We think that it's because there's something about the URDF file (or DAE file, which we generated from the URDF) that is being read incorrectly by OpenRave. We've been able to do this successfully with the Baxter using the instructions here: http://sdk.rethinkrobotics.com/wiki/Custom_IKFast_for_your_Baxter. Could you please help us get IK Fast to build on the Sawyer arm? Thanks!
  8. 1 point
    Hi- the 4kg payload includes the gripper/EOAT. Hope that helps! Reina
  9. 1 point
    Found it, it can be configured using intera studio!
  10. 1 point
    Hi lr101095, I moved this post to the SDK forum where I think it will get more attention.
  11. 1 point
    The short answer is no, the SDK releases are tied to particular versions of compatibility on the Sawyer robot. This is needed because some interfaces or ROS messages *onboard the robot* change between releases, which could lead you to the "ROS message md5 sum mismatch" error if you tried to use a different version of the SDK with the real robot and the message you need has changed. You can see the compatibility version dictionary directly inside the SDK: https://github.com/RethinkRobotics/intera_sdk/blob/master/intera_interface/src/intera_interface/settings.py With that said, the SDK is open source, and you can modify that settings file as you like to force the SDK to work with a different version of the robot. I would not recommend this, as some messages will be broken. Rethink will not have tested and QA'd that software combination, and we cannot support any errors you run into as a result. Final thought, Sawyer in Gazebo requires you to be running Ubuntu 16.04 and ROS Kinetic, so you might needed to upgrade your workstation if you'd like to use Sawyer in Gazebo. Hope this helps! ~ Ian
  12. 1 point
    Thanks Don, have also just found that there's a ROS param for the shipping pose. For others reference you can get it using rosparam get /named_poses/right/poses/shipping Or directly from .../src/sawyer_robot/sawyer_description/params/named_poses.yaml
  13. 1 point
    Hi Senaa, This is possible if you boot into Intera. You can select the shipping pose option to shut down. http://mfg.rethinkrobotics.com/intera/Head_Screen_Menu#Shipping_Pose Best, Don
  14. 1 point
    Hi, is there an officially supported way to obtain Jacobians for Sawyer by now? Using MoveIt seems to be a little bit of an overkill. Thanks! Frederik
  15. 1 point
    Hi snpowers, We will make an announcement on this forum when Gazebo integration is complete. Best, Don
  16. 1 point
    Hi Bruce, I put mine at the beginning of the list to be sure it tries to connect to it first as it cannot connect to the other ones (because no internet). You have done it well You are connected to your robot via ethernet cable, so you certainly have edited intera.sh when installing ROS and Sawyer SDK: http://sdk.rethinkrobotics.com/intera/Workstation_Setup#Configure_Robot_Communication.2FROS_Workspace The tutorial asks to fulfill your_ip="192.168.XXX.XXX" in this ./intera.sh. It is this same address that you should give to Sawyer. In my configuration, this address is static. That's weird... Maybe it is not eth0 if you have multiple ethernet port or a switch. Try ifconfig and look for eth something, there should be the same address as the one you set in intera.sh Clément
  17. 1 point
    Hi Bruce, I have the same configuration. To make the synchronisation of the clocks, you have to follow the following steps: run sudo gedit /etc/ntp.conf on your computer under the “# Use servers from the NTP Pool Project” section, you can specify to use ntp server addresses close to your location. Just add the keyword iburst at the end of each server line to force our computer ntp server to synchronize its current time with these servers as soon as it is launched. You should have something like: server 0.ubuntu.pool.ntp.org iburst server 1.ubuntu.pool.ntp.org iburst server 2.ubuntu.pool.ntp.org iburst server 3.ubuntu.pool.ntp.org iburst under the ”# Use Ubuntu's ntp server as a fallback. ” section, add the following lines: server 127.127.1.0 fudge 127.127.1.0 stratum 8 At the end of the file add the following lines: # Allow LAN machines to synchronize with this ntp server restrict 169.254.0.0 mask 255.255.0.0 nomodify notrap This will allow machines present on the network 169.254.0.0 to get the current time this computer. You have to put your network address (you can find it with ifconfig eth0). The server should now be operational just run sudo /etc/init.d/ntp restart to restart it. The next step is to tell Sawyer to connect to this server to synchronize with the computer's clock. To do this: enter Sawyer's FSM menu. To enter the FSM menu, reboot the robot and only start hitting Ctrl+F when Sawyer face appear. Continue until a menu appears (it is very very long like 1 or 2 min) click on “Configuration” button in the NTP server list, add the static ip of the computer in first position. Note: don't forget to put a comma to separate servers' addresses. Set the current location as needed. click “save” button and reboot Sawyer. Everything should work. Clément
  18. 1 point
    I was wondering if there is a way to specify in Intera the head movement? Such as keep the head in passive or active mode. There are times where I am running a program and want the head to stay passive, but it wants to be active, and vice versa.
  19. 1 point
    HI Senaa, Sorry to hear you are having this issue. This is likely a hardware or connection issue on either of the two embedded cameras. I'll take this off-line from the forum and troubleshoot with you. pat
  20. 1 point
    Greetings Sawyer SDK Users, We are pleased to announce the release of a new version of the Sawyer Intera SDK software – v5.1.0. SDK 5.1.0 is a release focused on improving the Intera SDK user experience and added further improvements to motion quality. You can find a complete set of SDK-related release notes here. The Intera 5.1 update also allows for any user to reboot between Rethink's Python and ROS-based SDK, and the new Intera 5.1 manufacturing software with behavior trees through the FSM. From this point forward, both Intera Manufacturing and SDK upgrades are installed through the same update files. If your Sawyer robot is currently running SDK 5.0.4, please follow this Software Update tutorial to upgrade your robot to Intera 5.1.0. Running the $ wstool update command from the top of your ROS workspace will pull in the Intera 5.1.0 changes to update your workstation. We have provided examples and code walk throughs for many aspects of the Sawyer's Intera SDK, so that you can get working quickly as soon as you install the SDK. Happy Researching! ~ Ian McMahon
  21. 1 point
    I'm not 100% sure, as I do not know the contents of GetPose.py, but your issue might be that 'Limb' needs to be capitalized when instantiating the class. Does something like this work in your environment? import rospy import intera_interface rospy.init_node("getpose") r = intera_interface.Limb('right')
  22. 1 point
    Hi Josh, We don't directly supply Sawyer's Jacobian, but it is possible to use tools to calculate it using Sawyers URDF. The KDL library is compatible with all URDF's so you should be able to use it with Sawyer. However, Baxter_PyKDL was a hackathon project that Rethink does not actively support. Feel free to use whatever you find there and tailor it to Sawyer and your needs. Best regards, ~ Ian
  23. 1 point
    Hi Josh, How are you commanding the arm's joints? If you're working in Position Mode, the joint stiffness cannot be updated. In Torque Mode, you can increase the amount of Torque each joint applies, but that depends on the controller you're designing. Best, ~ Ian
  24. 1 point
    Hi Eash, It seems you are pinging your Robot's serial number, rather than your Controller Box's serial number. Sawyer is a bit different than Baxter in that the Controller Box is separate, and your robot's hostname is defaulted as the Controller's serial number. The serial number can be located on the back of the robot's Controller Box. So instead it will look something like: [intera - http://021xxxCPxxxxx.local:11311] user@ubuntu:~/ros_ws$ ping 021xxxCPxxxxx.local ping: unknown host 021xxxCPxxxxx.local Let us know if this solves your issue. Best regards, ~ Ian
  25. 1 point
    Hi Josh, At boot time, Sawyer does read its joint control board (JCB) configurations and construct its URDF, but these values and Sawyer's joint range & transform frames are fixed at manufacture time. What values are you measuring and how are they significantly different from day to day? Just as an FYI, I'd recommend using the transform from /base to either /head_camera or /right_hand_camera frames if you're interested in where the camera is oriented with respect to the robot's base. Best, ~ Ian
This leaderboard is set to New York/GMT-04:00