Leaderboard


Popular Content

Showing content with the highest reputation on 03/19/2018 in all areas

  1. 1 point
    The short answer is no, the SDK releases are tied to particular versions of compatibility on the Sawyer robot. This is needed because some interfaces or ROS messages *onboard the robot* change between releases, which could lead you to the "ROS message md5 sum mismatch" error if you tried to use a different version of the SDK with the real robot and the message you need has changed. You can see the compatibility version dictionary directly inside the SDK: https://github.com/RethinkRobotics/intera_sdk/blob/master/intera_interface/src/intera_interface/settings.py With that said, the SDK is open source, and you can modify that settings file as you like to force the SDK to work with a different version of the robot. I would not recommend this, as some messages will be broken. Rethink will not have tested and QA'd that software combination, and we cannot support any errors you run into as a result. Final thought, Sawyer in Gazebo requires you to be running Ubuntu 16.04 and ROS Kinetic, so you might needed to upgrade your workstation if you'd like to use Sawyer in Gazebo. Hope this helps! ~ Ian
  2. 1 point
    Thanks Don, have also just found that there's a ROS param for the shipping pose. For others reference you can get it using rosparam get /named_poses/right/poses/shipping Or directly from .../src/sawyer_robot/sawyer_description/params/named_poses.yaml
This leaderboard is set to New York/GMT-04:00